ViewDolly(Double, Double, Double) Method
|
Translates the camera position and target by
the specified camera coordinate dolly amount.
Namespace: Teigha.GraphicsSystem
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public virtual void Dolly(
double xDolly,
double yDolly,
double zDolly
)
Public Overridable Sub Dolly (
xDolly As Double,
yDolly As Double,
zDolly As Double
)
public:
virtual void Dolly(
double xDolly,
double yDolly,
double zDolly
)
abstract Dolly :
xDolly : float *
yDolly : float *
zDolly : float -> unit
override Dolly :
xDolly : float *
yDolly : float *
zDolly : float -> unit
Parameters
- xDolly Double
- [in] Camera coordinate X dolly amount.
- yDolly Double
- [in] Camera coordinate Y dolly amount.
- zDolly Double
- [in] Camera coordinate Z dolly amount.
Remarks
Camera coordinates
are relative to the view of a target from a camera. * The Y-axis is
along the up vector. * The Z-axis is along the vector from the
camera position to the target. * The X-axis is the cross product of
the Y-axis and the Z-axis.
See Also