TableStyleSetGridVisibility Method
|
Sets the grid visibility for the specified
gridline types and row types.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public virtual void SetGridVisibility(
bool visible,
int gridLineTypes,
int rowTypes
)
Public Overridable Sub SetGridVisibility (
visible As Boolean,
gridLineTypes As Integer,
rowTypes As Integer
)
public:
virtual void SetGridVisibility(
bool visible,
int gridLineTypes,
int rowTypes
)
abstract SetGridVisibility :
visible : bool *
gridLineTypes : int *
rowTypes : int -> unit
override SetGridVisibility :
visible : bool *
gridLineTypes : int *
rowTypes : int -> unit
Parameters
- visible Boolean
- [in] Visibility status.
- gridLineTypes Int32
- [in] Gridline types.
- rowTypes Int32
- [in] Row types.
Remarks
The gridLineTypes
parameter can be a combination of one or more of the following:
NameValueDescriptionHorizontalTop 0x01 Top or
bottom horizontal grid line of the table, depending on the flow
direction of the table rows (down or up). HorizontalInside 0x02 All
horizontal grid lines, excluding the bottom and top grid lines.
HorizontalBottom 0x04 Bottom or top horizontal grid line of the
table, depending on the flow direction of the table rows (down or
up). VerticalLeft 0x08 The grid line at the left edge of the table.
VerticalInside 0x10 All vertical grid lines, excluding the left and
right grid lines. VerticalRight 0x20 The grid line at the right
edge of the table.
See Also