Orbits the camera about the target by the
specified amounts.
Namespace: Teigha.GraphicsSystem
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public virtual void Orbit(
double xOrbit,
double yOrbit
)
Public Overridable Sub Orbit (
xOrbit As Double,
yOrbit As Double
)
public:
virtual void Orbit(
double xOrbit,
double yOrbit
)
abstract Orbit :
xOrbit : float *
yOrbit : float -> unit
override Orbit :
xOrbit : float *
yOrbit : float -> unit
Parameters
- xOrbit Double
- [in] X-axis orbit.
- yOrbit Double
- [in] Y-axis orbit.
Remarks
The camera moves
on the surface of a sphere whose center is the camera target and
whose radius is the distance from the camera position to its
target. * The camera is first rotated about an axis parallel to the
X-axis and passing through the target. * The camera is next rotated
about an axis parallel to the Y-axis and passing through the
target. Camera coordinates are relative to the view of a target
from a camera. * The Y-axis is along the up vector. * The Z-axis is
along the vector from the camera position to the target. * The
X-axis is the cross product of the Y-axis and the Z-axis. All
angles are expressed in radians.
See Also