Solid3dCreateWedge Method

Creates a WCS-aligned wedge centered about the world origin.

Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public virtual void CreateWedge(
        double lengthAlongX,
        double lengthAlongY,
        double lengthAlongZ
)

Parameters

lengthAlongX  Double
[in] Dimension along the WCS x-axis.
lengthAlongY  Double
[in] Dimension along the WCS y-axis.
lengthAlongZ  Double
[in] Dimension along the WCS z-axis.
Remarks
The inclined face is defined by the points:
  ( lengthAlongX/2, -lengthAlongY/2, -lengthAlongZ/2)
  (-lengthAlongX/2, -lengthAlongY/2,  lengthAlongZ/2)
  ( lengthAlongX/2,  lengthAlongY/2, -lengthAlongZ/2)
  (-lengthAlongX/2,  lengthAlongY/2,  lengthAlongZ/2)
The following constraints are applied: * lengthAlongX >= 1e-6 * lengthAlongY >= 1e-6 * lengthAlongZ >= 1e-6
See Also

©  Bricsys NV. All rights reserved.