LoftOptionsNormalOption Enumeration
|
This enumeration specifies plane normal
lofting options.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public enum LoftOptionsNormalOption
Public Enumeration LoftOptionsNormalOption
public enum class LoftOptionsNormalOption
type LoftOptionsNormalOption
Members
Member name |
Value |
Description |
NoNormal |
0 |
Plane normal lofting is off: surface direction is calculated at
each cross-section. |
FirstNormal |
1 |
Direction of the surface at the first cross-section is the same
as the plane normal of the cross-section. |
LastNormal |
2 |
Direction of the surface at the last cross-section is the same
as the plane normal of the cross-section. |
EndsNormal |
3 |
Direction of the surface at the first and last cross-sections
is the same as the plane normal of the cross-section. |
AllNormal |
4 |
Direction of the surface at each cross-section is the same as
the plane normal of the cross-section. |
UseDraftAngles |
5 |
Direction of the surface at each cross-section is the same as
the plane normal of the cross-section. |
See Also