Represents the state of the field.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
[FlagsAttribute]
public enum FieldState
<FlagsAttribute>
Public Enumeration FieldState
[FlagsAttribute]
public enum class FieldState
[<FlagsAttribute>]
type FieldState
Members
Member name |
Value |
Description |
Initialized |
1 |
Field is not initialized yet. |
Compiled |
2 |
Field has been compiled. |
Modified |
4 |
Field has been modified but is not evaluated yet. |
Evaluated |
8 |
Field has been evaluated. Use the Field.EvaluationStatus property to retrieve the
evaluation status. |
HasCache |
16 |
The field has a cache of the evaluated result. |
HasFormattedString |
32 |
The field has a formatted string. |
See Also