NurbSurfaceGetIsolineAtU Method
|
Returns the isolines at the specified u value.
The isolines are created in the v-direction. If there are holes in
the surface, there could be a number of isoline segments at a
specified u value.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public Curve[] GetIsolineAtU(
double dU
)
Public Function GetIsolineAtU (
dU As Double
) As Curve()
public:
array<Curve^>^ GetIsolineAtU(
double dU
)
member GetIsolineAtU :
dU : float -> Curve[]
Parameters
- dU Double
- [in] U parameter.
Return Value
Curve
Remarks
If the surface
doesn't contain any NURBS information, the method throws the
eFail exception.
See Also