TransientManagerEraseTransients Method

Erases all drawables from the specified drawable mode and order.

Namespace: Teigha.GraphicsInterface
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public bool EraseTransients(
        TransientDrawingMode mode,
        int subDrawingMode,
        IntegerCollection viewportNumbers
)

Parameters

mode  TransientDrawingMode
[in] Transient drawable mode.
subDrawingMode  Int32
[in] Draw order index.
viewportNumbers  IntegerCollection
[in] Collection of viewport indices.

Return Value

Boolean
true if the drawables are erased or false in one of the following cases: * The passed mode is greater than or equal to the TransientDrawingMode.Count. * The specified draw order index exceeds the maximum value of the signed integer.
See Also

©  Bricsys NV. All rights reserved.