Solid3dExtrudeAlongPath Method

Creates a solid by extruding a region along a path curve.

Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public virtual void ExtrudeAlongPath(
        Region region,
        Curve path,
        double taperAngle
)

Parameters

region  Region
[in] Region to extrude.
path  Curve
[in] Curve object to extrude along.
taperAngle  Double
[in] Taper angle in radians in the range [-OdaPI/2..OdaPI/2].
Remarks
The entity path must not have self-intersections, and it is recommended that the following constraints are applied: |taper Angle| >= 1e-6. This method is implemented for the Spatial modeler and partially for ModelerGeometry. The path parameter must be one of the following: * Line * Arc * Circle * Ellipse * Spline * 2D polyline * Non-spline fit 3D polyline
See Also

©  Bricsys NV. All rights reserved.