TableCopyOptions Enumeration
|
This enum class represents the table copy
options.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public enum TableCopyOptions
Public Enumeration TableCopyOptions
public enum class TableCopyOptions
Members
Member name |
Value |
Description |
None |
0 |
No options are used. |
ExpandOrContractTable |
1 |
Creates new rows/columns or deletes them for the target range
so the source range fully fits it. |
SkipContent |
2 |
Content is not copied. |
SkipValue |
4 |
If content is a value, it is not copied. |
SkipField |
8 |
If content is a field, it is not copied. |
SkipFormula |
16 |
If content is a formula, it is not copied. |
SkipBlock |
32 |
If content is a block, it is not copied. |
SkipDataLink |
64 |
Data links are not copied. |
SkipLabelCell |
128 |
If content is a label cell, it is not copied. |
SkipDataCell |
256 |
If content is a data cell, it is not copied. |
SkipFormat |
512 |
Format is not copied. |
SkipCellStyle |
1,024 |
Cell style is not copied. |
ConvertFormatToOverrides |
2,048 |
Converts formats to overrides after copying. |
SkipCellState |
4,096 |
Cell state is not copied. |
SkipContentFormat |
8,192 |
Content format is not copied. |
SkipDissimilarContentFormat |
16,384 |
If content types are not the same, content format is not
copied. |
SkipGeometry |
32,768 |
Geometric information (column width, row height, etc.) is not
copied. |
SkipMerges |
65,536 |
Cell merges are not copied. |
FillTarget |
131,072 |
The target range is filled by repeatedly copying the source
range. |
OverwriteReadOnlyContent |
262,144 |
Overwrite a target cell if it has read-only content. |
OverwriteReadOnlyFormat |
524,288 |
Overwrite a target cell if it has read-only format. |
OverwriteContentModifiedAfterUpdate |
1,048,576 |
|
OverwriteFormatModifiedAfterUpdate |
2,097,152 |
|
OnlyContentModifiedAfterUpdate |
4,194,304 |
|
OnlyFormatModifiedAfterUpdate |
8,388,608 |
|
TableCopyRowHeight |
16,777,216 |
Row height is copied while copying cells. |
TableCopyColumnWidth |
33,554,432 |
Column width is copied while copying cells. |
See Also