AdvancedSupportFlags Enumeration

Flags used to advertise support for advanced capabilities

Namespace: Teigha.Runtime
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
[FlagsAttribute]
public enum AdvancedSupportFlags
Members
Member name Value Description
None 0 No advanced support
MultiThreadRenderInLayout 1 WorldDraw() and ViewportDraw() calls from different threads are supported for a top level drawable
MultiThreadRenderInBlock 2 WorldDraw() and ViewportDraw() calls from different threads are supported for a drawable within a compound object
MultiThreadRenderNested 4 WorldDraw() and ViewportDraw() calls from different threads are supported for a deeply nested drawable
MultiThreadRenderMask 15 Mask value for all rendering related flags
MultiThreadLoading 128 Multithreaded loading from persistent storage is supported
HistoryAware 256 Object's undo information can be saved in a persistent history file
See Also

©  Bricsys NV. All rights reserved.