CellProperties Enumeration
|
This enum class represents cell
properties.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public enum CellProperties
Public Enumeration CellProperties
public enum class CellProperties
Members
Member name |
Value |
Description |
Invalid |
0 |
Invalid property. |
DataType |
1 |
Data type. |
DataFormat |
2 |
Data format. |
Rotation |
4 |
Rotation. |
Scale |
8 |
Scale. |
Alignment |
16 |
Alignment. |
ContentColor |
32 |
Content color. |
TextStyle |
64 |
Text style. |
TextHeight |
128 |
Text height. |
AutoScale |
256 |
Auto scale. |
BackgroundColor |
512 |
Background color. |
MarginLeft |
1,024 |
Left margin. |
MarginTop |
2,048 |
Top margin. |
MarginRight |
4,096 |
Right margin. |
MarginBottom |
8,192 |
Bottom margin. |
ContentLayout |
16,384 |
Content layout. |
MergeAll |
32,768 |
Merge all cells flag. |
FlowDirBtoT |
65,536 |
Table flow direction. |
MarginHorzSpacing |
131,072 |
Horizontal spacing margin. |
MarginVertSpacing |
262,144 |
Vertical spacing margin. |
See Also