FrontAndBackClipping Structure

This .NET class stores data that is used for clipping viewports.
Inheritance Hierarchy
SystemObject
  SystemValueType
    Teigha.GraphicsInterfaceFrontAndBackClipping

Namespace: Teigha.GraphicsInterface
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public struct FrontAndBackClipping

The FrontAndBackClipping type exposes the following members.

Constructors
  Name Description
Public method FrontAndBackClipping Constructor for the FrontAndBackClipping class. Specifies whether front and back clipping is used with the provided front and back clip distances.
Top
Properties
  Name Description
Public property Back  
Public property ClipBack  
Public property ClipFront  
Public property Front  
Top
Methods
  Name Description
Public method Equals Checks objects for equality.
(Overrides ValueTypeEquals(Object))
Public method GetHashCode Retrieves the object hash code.
(Overrides ValueTypeGetHashCode)
Public method IsEqualTo(FrontAndBackClipping) Checks whether this object is equal to the specified object.
Public method IsEqualTo(FrontAndBackClipping, Tolerance) Checks whether this object is equal to the specified object according to a tolerance.
Top
Operators
  Name Description
Public operatorStatic member Equality(FrontAndBackClipping, FrontAndBackClipping) Equality operator for the FrontAndBackClipping class. Checks whether the specified objects are equal.
Public operatorStatic member Inequality(FrontAndBackClipping, FrontAndBackClipping) Inequality operator for the FrontAndBackClipping class. Checks whether the specified objects are not equal.
Top
See Also

©  Bricsys NV. All rights reserved.