Introduces a polygon to the vectorization
context.
Namespace: Teigha.GraphicsInterface
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public abstract bool Polygon(
Point3dCollection points
)
Public MustOverride Function Polygon (
points As Point3dCollection
) As Boolean
public:
virtual bool Polygon(
Point3dCollection^ points
) abstract
abstract Polygon :
points : Point3dCollection -> bool
Parameters
- points Point3dCollection
- [in] Array of vertices for the polygon.
Return Value
Boolean
true. This method also throws a corresponding exception if it
fails.
Remarks
The polygon is
filled and takes on the current color. Use polyline() to render
unfilled areas. The polygon is rendered as a series of lines
connecting the first point in vertexList to the second, the second
to the third, etc. All points must be coplanar.
See Also