Pans the camera by the specified X and Y
values.
Namespace: Teigha.GraphicsSystem
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public virtual void Pan(
double xPan,
double yPan
)
Public Overridable Sub Pan (
xPan As Double,
yPan As Double
)
public:
virtual void Pan(
double xPan,
double yPan
)
abstract Pan :
xPan : float *
yPan : float -> unit
override Pan :
xPan : float *
yPan : float -> unit
Parameters
- xPan Double
- [in] Cross product of the up vector and the eye vector.
- yPan Double
- [in] Up vector.
Remarks
During a pan, the
camera position and distance from the position to target are
locked; the camera target moves along the surface of a sphere
described by these constraints. The X and Y parameters are in
radians and correspond to the angles traversed on this sphere along
the cross product of the up vector and the eye vector (X) and along
the up vector (Y).
See Also