acet-ini-get


(acet-ini-get  inifile  [ section  [ key  [ default ] ] ])

Retrieves settings / initialisation value from a file.

inifile is the file to be used (must include full pathname, no (findfile) operation is internally used)
section is the (optional) section name where the settings key is stored
key is the (optional) settings key to be queried

default is the (optional) value to be returned, if specified key does not exist in specified section

Comment characters : ; semicolon
Note : entries without having the '=' equal character are ignored


Special cases :

section (and key + default) is not specified : returns a list of all sections contained in the initfile
key (and default) is not specified : returns a list of all available settings keys contained in the initfile
default is not specified : if there is no entry with key under section, NIL will be returned

Returns the defined value (or default, if specified), NIL if the requested value is not present, or in case of an error.


©  Bricsys NV. All rights reserved.