bim:get-assigned-space


(bim:get-assigned-space  ename [asObject])

Returns the string name or entity name of the 'Space', to which the specified entity is assigned to, or NIL if that entity is not assigned to a 'Space' object.

Arguments

ename  the entity to query, as normal entity or as VLA object name

asObject  if specified and not NIL, the assigned 'Space' is returned as entity name, otherwise as the (string) name

Return

the space name (as string), resp. the space entity name, or NIL if the entity is not assigned to a space object

Example

(bim:set-assigned-space ent "Floor")  T
(bim:get-assigned-space ent)  "Floor"
(bim:get-assigned-space ent  T)  <Entity name: 81c45b50>

Remarks

important : the name of a space is not unique ! Unique identifiers are the GUID and also the "Number" of the space;
see (bim:set-assigned-space)



©  Bricsys NV. All rights reserved.