bim:set-namespace-label


(bim:set-namespace-label  nameSpace  newLabel)

Assigns a new label newLabel for the specified nameSpace.

Arguments

nameSpace  (string) the NameSpace to set visible or invisible (can be the "name" or the "label" of a BIM NameSpace)

newLabel  (string) defines the new label for the specified NameSpace

Return

T or NIL, indicating success or failure

Example

(vl-load-bim)
(bim:create-namespace "MyNameSpace" "MyNameSpace-X" T)
(bim:set-namespace-label "MyNameSpace" "MyNewNameSpace")  T
(bim:set-namespace-label "MyNameSpace-X" "MyNewNameSpace")  T

Remarks

the nameSpace is not case-sensitive; both "name" and "label" of a BIM NameSpace are verified



©  Bricsys NV. All rights reserved.