bim:set-namespace-visible


(bim:set-namespace-visible  nameSpace  visible)

Defines whether the specified nameSpace is visible or invisible.

Arguments

nameSpace  (string) the NameSpace to set visible or invisible (can be the "name" or the "label" of a BIM NameSpace)

visible  (T/NIL) defines whether the specified NameSpace is visible or invisible

Return

T or NIL, indicating success or failure

Example

(vl-load-bim)
(bim:create-namespace "MyNameSpace" "MyNameSpace-X" T)
(bim:set-namespace-visible "MyNameSpace" NIL)  T
(bim:set-namespace-visible "MyNameSpace-X" T)  T

Remarks

the nameSpace is not case-sensitive; both "name" and "label" of a BIM NameSpace are verified



©  Bricsys NV. All rights reserved.