civil:converter-attachedlabels


(civil:converter-attachedlabels  converter  handle)

Returns the list of converted label entities, attached to the specified alignment or surface C3D Entity handle (integer);
only valid after (civil:converter-convert converter) has been used !

Arguments

converter  (handle, integer)  the converter object as instantiated by (civil:get-converter)
handle  (handle, integer)  the alignment or surface C3D entity to retrieve the attached labels for

Return

a list of ENAME, or NIL

Example

(vl-load-civil)
(setq converter (civil:get-converter 255))
(setq c3dents (civil:converter-get-c3d-entities converter))
(setq handle (nth 0 c3dents))
(setq res (civil:converter-convert converter c3dents))
(setq labels (civil:converter-attachedlabels converter handle))
NIL

Remarks

for any other C3D entity type, NIL will be returned.



©  Bricsys NV. All rights reserved.