civil:converter-convert
(civil:converter-convert converter
[handles])
Converts (extracts) all C3D entities, or the
subset as specified by optional handles list (list of integer)
of native C3D entities.
Arguments
|
converter (handle, integer) the converter object as
instantiated by (civil:get-converter)
handles (list of integer handles, optional) if
provided, a list of integer handles for the C3D entities to be
converted; if omitted, all suitable C3D entities are
converted
|
Return
|
returns a list of 2 sub-lists
:
first list contains <handle . ename>
pairs for original + converted entities;
second list contains all other entities
created by conversion (can be NIL);
NIL is returned in case of an error, or if no
C3D entities are present, or could be converted
|
Example
|
(vl-load-civil)
(setq converter (civil:get-converter
255))
(setq c3dents
(civil:converter-get-c3d-entities converter)
(setq res (civil:converter-convert converter
c3dents)))
(
((<Entity name: a27a5a30> . 1852005136)
(<Entity name: a27a4130> . 1852004976) (<Entity name:
a27a5870> . 1852018880) (<Entity name: a27a50b0> .
1852006336) (<Entity name: a27a31f0> .
1852022720))
(<Entity name: a27af570> <Entity
name: a27af530> <Entity name: a27af930> <Entity name:
a27a5bf0> <Entity name: a27a70b0> <Entity name:
a27a4ef0>)
)
|
Remarks
|
|