civil:converter-get-c3d-alignmenttype


(civil:converter-get-c3d-alignmenttype  handle)

Returns the AlignmentType for the specified C3D entity handle (integer).

Arguments

handle  (handle, integer)  the C3D entity to retrieve the alignment type for

Return

the AlignmentType (integer) on success, or NIL if the specified handle does not refer to a C3D Alignment entity

Example

(vl-load-civil)  T
(setq converter (civil:get-converter 255))  1857342512
(setq c3dents (civil:converter-get-c3d-entities converter))  (1719921328  1855578352  1719922032  1855582912  1855579152)
(setq handle (nth 0 c3dents))  1861791120
(setq align (civil:converter-get-c3d-alignmenttype handle))  NIL
(setq handle (nth 3 c3dents))  2097478000
(setq align (civil:converter-get-c3d-alignmenttype handle))  0

Remarks

for AlignmentType values, please see ECivil3dAlignmentType in Type Constants



©  Bricsys NV. All rights reserved.