civil:converter-get-c3d-info


(civil:converter-get-c3d-info  handle)

Returns a list of definition data for the specified C3D entity handle (integer).

Arguments

handle  (handle, integer)  the C3D entity to retrieve the informations for

Return

returns the list of 'C3D Entity Definitions' (list of strings + integers + ename) on success, or NIL

Example

(vl-load-civil)  T
(setq converter (civil:get-converter 255))  2103594208
(setq c3dents (civil:converter-get-c3d-entities converter))  (1719921328  1855578352  1719922032  1855582912  1855579152)
(setq handle (nth 0 c3dents))  1852301632
(setq data  (civil:converter-get-c3d-info handle))  ("Existing Ground" "" 2 <Entity name: 665fa3c0>)

Remarks

sequence of definition data : (Name  Description  EntityType  Ename);
for EntityType values, please see ECivil3dEntityType in Type Constants



©  Bricsys NV. All rights reserved.