civil:converter-get-c3d-basealignment


(civil:converter-get-c3d-basealignment  handle)

Returns the base alignment definition for the specified C3D Profile entity handle (integer).

Arguments

handle  (handle, integer)  the C3D entity to retrieve the base alignment for

Return

the base alignment definition data (list, same as returned by (civil:converter-get-c3d-info) function) on success, or NIL if the specified handle does not refer to a C3D Profile entity

Example

(vl-load-civil)
(setq converter (civil:get-converter 255))  1860981280
(setq c3dents (civil:converter-get-c3d-entities converter))  (1719921328  1855578352  1719922032  1855582912  1855579152)
(setq handle (nth 0 c3dents))  2093508048
(setq profile (civil:converter-get-c3d-profiletype handle))  NIL
(setq handle (nth 3 c3dents))  2093979968
(setq profile (civil:converter-get-c3d-profiletype handle))  2
(setq align (civil:converter-get-c3d-basealignment handle))  ("Alignment - (1)" "" 0 <Entity name: 557cc8d0>)

Remarks

for the base alignment definition list, please see (civil:converter-get-c3d-info)



©  Bricsys NV. All rights reserved.