mech:get-componentparameternames


(mech:get-componentparameternames  idBlockRef)

returns the GUI parameter names of the constrained idBlockRef BlockReference entity (ename) as shown in Mechanical Browser.

Arguments

idBlockRef (ename) the BlockReference entity to be queried

Return

the list of "parameter names" (strings) for the specified BlockReference;
NIL if no constraints are assigned

Example

(vl-load-mech)  2
(setq ent (car (entsel))) <Entity name: 4b9fb730>
(setq res (mech:get-componentparameternames ent))  ("H" "W" "D")

Remarks


Note




©  Bricsys NV. All rights reserved.