vl-subent-atpoint


(vl-subent-atpoint  point  [ subentTypes ])

Returns the subentity definition list of the entity/subentity/subentities found at specified point (point list), filtered by subentTypes (integer bit flags); returns list (point <subent-definition> <subent-definition> ... <subent-definition>) or NIL

Arguments

point  (2d/3d point list) the geometric location where to require the specified main + sub entities

subentTypes  (integer bit-flags, optional) mask to define which sub-entities are required; if omitted, all main + sub entities are retrieved (bcSubentAll, see below)

Return

list (selectionpoint <subent-definition> <subent-definition> ... <subent-definition>), or NIL

Example

using a 3dSolid (box) :
(vl-subent-atpoint '(0 0 0))
((0.0 0.0 0.0)
 (4 7 <Entity name: 4accdd70>)
 (2 9 <Entity name: 4accdd70>)
 (2 6 <Entity name: 4accdd70>)
 (2 7 <Entity name: 4accdd70>)
 (1 4 <Entity name: 4accdd70>)
 (1 3 <Entity name: 4accdd70>)
 (1 2 <Entity name: 4accdd70>)
 (16 0 <Entity name: 4accdd70>)
)

Remarks

SubEntity selection constants :
these constants are bit-values and can be combined



Symbolic Constant

Value



bcSubentFace

1

specifies Face subentity type


bcSubentEdge

2

specifies Edge subentity type


bcSubentVertex

4

specifies Vertex subentity type


bcSubentMain

16

specifies the Main entity






bcSubentAll

23

combines bcSubentFace + bcSubentEdge + bcSubentVertex + bcSubentMain

<subent-definition>

list of subentity type, subentity index (GsMarker), main entity
(type index ename)



©  Bricsys NV. All rights reserved.