vl-subent-select


(vl-subent-select  [ msg ]  [ subentTypes  [ osmode ]])

Queries the user by optional msg (string) prompt message to select a point using the optional object snap mode osmode (integer, default 591, end+mid+center+node+insertion+nearest) to return the subentity definition list of the entity/subentity found at selected point, and filtered by subentTypes (integer bit flags);
returns list (point <subent-definition> <subent-definition> ... <subent-definition>) or NIL

Arguments

msg  (string, optional)  the prompt message to be shown; if omitted, "Select entity:" is shown

subentTypes  (integer bit-flags, optional) mask to define which sub-entities are required; if omitted, all main + sub entities are retrieved (bcSubentAll, see below)

osmode  (integer, optional) the object snap mode to be used; if omitted, 591 is used : end + mid + center + node + insertion + nearest)

Return

list (selectionpoint <subent-definition> <subent-definition> ... <subent-definition>), or NIL

Example

(setq sel (vl-subent-select))
Select entity:
((1892.5740146595 816.849680167082 336.77795566434)
 (1 1 <Entity name: 4a52d600>)
 (1 5 <Entity name: 4a52d600>)
 (16 0 <Entity name: 4a52d600>)
)

Remarks

SubEntity selection constants :
these constants are bit-values and can be combined



Symbolic Constant

Value



bcSubentFace

1

specifies Face subentity type


bcSubentEdge

2

specifies Edge subentity type


bcSubentVertex

4

specifies Vertex subentity type


bcSubentMain

16

specifies the Main entity






bcSubentAll

23

combines bcSubentFace + bcSubentEdge + bcSubentVertex + bcSubentMain

<subent-definition>

list of subentity type, subentity index (GsMarker), main entity
(type index ename)



©  Bricsys NV. All rights reserved.