(snvalid symbol [flag])


snvalid (symbolname valid) Determine whether the symbol is made-up of valid characters.


This function tests whether a  given symbol would be a valid name within the symbol tables, including "LAYER", "LTYPE", "VIEW", "STYLE", "BLOCK", "UCS", "VPORT", "DIMSTYLE", and "APPID".

The optional flag argument toggles whether the vertical bar ( | ) character is valid:

 

Flag Meaning
0 vertical bar is NOT allowed.
1 vertical bar is allowed.

 

Examples

Code

Returns

Remark

(snvalid "Foo Bar")

T

 

(snvalid " Foo Bar ")

NIL

leading / trailing space

(snvalid "Foo|Bar")

NIL

vertical bar illegal by default

(snvalid "Foo|Bar" 1)

T

flag=1 accept vertical bar (|)

 

Tell me about...

(tblsearch table-name symbol [flag])

LISP Compatibility

Programming Overview of LISP (LISt Processing) Language

 


Bricscad™ is commercialized by Bricsys NV. Bricsys NV and Vondle NV are fully owned subsidiaries of Menhirs NV. © 2001- Menhirs NV - All rights reserved.