Class AcadSpline
Member of BricscadDb
The Spline object is a free-form curve generated along the path of three or more control points. The curve passes through the start and end points, but does not necessarily pass through the intermediate control points. To create a Spline object, use the AddSpline or method. To access a spline, use the following methods and properties:
Methods | Properties |
---|---|
AddFitPoint | Application |
ArrayPolar | Area |
ArrayRectangular | Closed |
Copy | ControlPoints |
Delete | Degree |
DeleteFitPoint | Document |
ElevateOrder | EndTangent |
GetBoundingBox | FitPoints |
GetControlPoint | FitTolerance |
GetExtensionDictionary | Handle |
GetFitPoint | HasExtensionDictionary |
GetWeight | Hyperlinks |
GetXData | IsPeriodic |
Highlight | Isplanar |
IntersectWith | IsRational |
Mirror | Knots |
Mirror3D | Layer |
Move | Linetype |
Offset | LinetypeScale |
PurgeFitData | Lineweight |
Reverse | NumberOfControlPoints |
Rotate | NumberOfFitPoints |
Rotate3D | ObjectID |
ScaleEntity | ObjectName |
SetControlPoint | OwnerID |
SetFitPoint | PlotStyleName |
SetWeight | StartTangent |
SetXData | TrueColor |
TransformBy | Visible |
Update | Weights |
Bricscad™ is commercialized by Bricsys NV. Bricsys NV and Vondle NV are fully owned subsidiaries of Menhirs NV. © 2001- Menhirs NV - All rights reserved. |