AcadDwfUnderlayClass Class

Inheritance Hierarchy
SystemObject
  BricscadDbAcadDwfUnderlayClass

Namespace: BricscadDb
Assembly: BricscadDb (in BricscadDb.dll) Version: 25.0.0.0
Syntax
public class AcadDwfUnderlayClass : IAcadUnderlay, 
        AcadDwfUnderlay, IAcadObjectEvents_Event, IAcadDwfUnderlay

The AcadDwfUnderlayClass type exposes the following members.

Properties
  Name Description
Public property AdjustForBackground  
Public property Application  
Public property ClippingEnabled  
Public property color  
Public property Contrast  
Public property Database  
Public property Document  
Public property DWFFormat  
Public property EntityName  
Public property EntityTransparency  
Public property EntityType  
Public property Fade  
Public property File  
Public property Handle  
Public property HasExtensionDictionary  
Public property Height  
Public property Hyperlinks  
Public property IAcadDwfUnderlay_AdjustForBackground  
Public property IAcadDwfUnderlay_Application  
Public property IAcadDwfUnderlay_ClippingEnabled  
Public property IAcadDwfUnderlay_color  
Public property IAcadDwfUnderlay_Contrast  
Public property IAcadDwfUnderlay_Database  
Public property IAcadDwfUnderlay_Document  
Public property IAcadDwfUnderlay_EntityName  
Public property IAcadDwfUnderlay_EntityTransparency  
Public property IAcadDwfUnderlay_EntityType  
Public property IAcadDwfUnderlay_Fade  
Public property IAcadDwfUnderlay_File  
Public property IAcadDwfUnderlay_Handle  
Public property IAcadDwfUnderlay_HasExtensionDictionary  
Public property IAcadDwfUnderlay_Height  
Public property IAcadDwfUnderlay_Hyperlinks  
Public property IAcadDwfUnderlay_ItemName  
Public property IAcadDwfUnderlay_Layer  
Public property IAcadDwfUnderlay_Linetype  
Public property IAcadDwfUnderlay_LinetypeScale  
Public property IAcadDwfUnderlay_Lineweight  
Public property IAcadDwfUnderlay_Material  
Public property IAcadDwfUnderlay_Monochrome  
Public property IAcadDwfUnderlay_ObjectID  
Public property IAcadDwfUnderlay_ObjectID32  
Public property IAcadDwfUnderlay_ObjectName  
Public property IAcadDwfUnderlay_OwnerID  
Public property IAcadDwfUnderlay_OwnerID32  
Public property IAcadDwfUnderlay_PlotStyleName  
Public property IAcadDwfUnderlay_Position  
Public property IAcadDwfUnderlay_Rotation  
Public property IAcadDwfUnderlay_ScaleFactor  
Public property IAcadDwfUnderlay_TrueColor  
Public property IAcadDwfUnderlay_UnderlayLayerOverrideApplied  
Public property IAcadDwfUnderlay_UnderlayName  
Public property IAcadDwfUnderlay_UnderlayVisibility  
Public property IAcadDwfUnderlay_Visible  
Public property IAcadDwfUnderlay_Width  
Public property ItemName  
Public property Layer  
Public property Linetype  
Public property LinetypeScale  
Public property Lineweight  
Public property Material  
Public property Monochrome  
Public property ObjectID  
Public property ObjectID32  
Public property ObjectName  
Public property OwnerID  
Public property OwnerID32  
Public property PlotStyleName  
Public property Position  
Public property Rotation  
Public property ScaleFactor  
Public property TrueColor  
Public property UnderlayLayerOverrideApplied  
Public property UnderlayName  
Public property UnderlayVisibility  
Public property Visible  
Public property Width  
Top
Methods
  Name Description
Public method add_Modified  
Public method ArrayPolar  
Public method ArrayRectangular  
Public method ClipBoundary  
Public method Copy  
Public method Delete  
Public method Erase  
Public method GetBoundingBox  
Public method GetExtensionDictionary  
Public method GetXData  
Public method Highlight  
Public method IAcadDwfUnderlay_ArrayPolar  
Public method IAcadDwfUnderlay_ArrayRectangular  
Public method IAcadDwfUnderlay_ClipBoundary  
Public method IAcadDwfUnderlay_Copy  
Public method IAcadDwfUnderlay_Delete  
Public method IAcadDwfUnderlay_Erase  
Public method IAcadDwfUnderlay_GetBoundingBox  
Public method IAcadDwfUnderlay_GetExtensionDictionary  
Public method IAcadDwfUnderlay_GetXData  
Public method IAcadDwfUnderlay_Highlight  
Public method IAcadDwfUnderlay_IntersectWith  
Public method IAcadDwfUnderlay_Mirror  
Public method IAcadDwfUnderlay_Mirror3D  
Public method IAcadDwfUnderlay_Move  
Public method IAcadDwfUnderlay_Rotate  
Public method IAcadDwfUnderlay_Rotate3D  
Public method IAcadDwfUnderlay_ScaleEntity  
Public method IAcadDwfUnderlay_SetXData  
Public method IAcadDwfUnderlay_TransformBy  
Public method IAcadDwfUnderlay_Update  
Public method IntersectWith  
Public method Mirror  
Public method Mirror3D  
Public method Move  
Public method remove_Modified  
Public method Rotate  
Public method Rotate3D  
Public method ScaleEntity  
Public method SetXData  
Public method TransformBy  
Public method Update  
Top
Events
  Name Description
Public event Modified  
Top
See Also

©  Bricsys NV. All rights reserved.