AcSmDatabaseClass Class

Inheritance Hierarchy
SystemObject
  BricscadSmAcSmDatabaseClass

Namespace: BricscadSm
Assembly: BricscadSm (in BricscadSm.dll) Version: 25.0.0.0
Syntax
public class AcSmDatabaseClass : IAcSmDatabase, 
        AcSmDatabase, IOdSmInternal

The AcSmDatabaseClass type exposes the following members.

Constructors
  Name Description
Public method AcSmDatabaseClass Initializes a new instance of the AcSmDatabaseClass class
Top
Methods
  Name Description
Public method Clear  
Public method FindAcDbObjectReferences  
Public method FindObject  
Public method GetClassID  
Public method GetCustomPropertyBag  
Public method GetDatabase  
Public method GetDbVersion  
Public method GetDesc  
Public method GetDirectlyOwnedObjects  
Public method GetDirectlyOwnedObjectsArray  
Public method GetEnumerator  
Public method GetFileName  
Public method GetImpl  
Public method GetIsDirty  
Public method GetIsTemporary  
Public method GetLockOwnerInfo  
Public method GetLockStatus  
Public method GetName  
Public method GetNewObjectId  
Public method GetObjectId  
Public method GetOwner  
Public method GetSheetSet  
Public method GetTemplateDstFileName  
Public method GetTypeName  
Public method InitNew  
Public method Load  
Public method LoadFromFile  
Public method LockDb  
Public method NotifyRegisteredEventHandlers  
Public method Register  
Public method RegisterOwner  
Public method Save  
Public method SetDesc  
Public method SetFileName  
Public method SetImpl  
Public method SetIsTemporary  
Public method SetName  
Public method SetOwner  
Public method UnlockDb  
Public method Unregister  
Public method UpdateInMemoryDwgHints  
Top
See Also

©  Bricsys NV. All rights reserved.