RxVariant Class

This class implements Variant objects within the ODA Platform.
Inheritance Hierarchy
SystemObject
  SystemMarshalByRefObject
    Teigha.RuntimeDisposableWrapper
      Teigha.RuntimeRXObject
        Teigha.RuntimeRxVariant

Namespace: Teigha.Runtime
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 25.3.0.0
Syntax
public class RxVariant : RXObject

The RxVariant type exposes the following members.

Constructors
  Name Description
Public method RxVariant Default constructor for the RxVariant class.
Public method RxVariant(Boolean) Constructor for the RxVariant class.
Public method RxVariant(Byte) Constructor for the RxVariant class.
Public method RxVariant(Double) Constructor for the RxVariant class.
Public method RxVariant(Int16) Constructor for the RxVariant class.
Public method RxVariant(Int32) Constructor for the RxVariant class.
Public method RxVariant(Int64) Constructor for the RxVariant class.
Public method RxVariant(IntPtr) Constructor for the RxVariant class.
Public method RxVariant(RXObject) Constructor for the RxVariant class.
Public method RxVariant(String) Constructor for the RxVariant class.
Public method RxVariant(UInt16) Constructor for the RxVariant class.
Public method RxVariant(UInt32) Constructor for the RxVariant class.
Protected method RxVariant(IntPtr, Boolean) Initializes a new instance of the RxVariant class
Top
Properties
  Name Description
Public property Boolean Property that represents a Boolean value.
Public property Double Property that represents double value.
Public property Int16 Property that represents Int16 value.
Public property Int32 Property that represents Int32 value.
Public property Int64 Property that represents Int64 value.
Public property Int8 Property that represents Int8 value.
Public property IntPtr Property that represents a pointer.
Public property Str Property that represents string value.
Public property Type Property that represents type of a value stored in this RxVariant object.
Public property UInt16 Property that represents UInt16 value.
Public property UInt32 Property that represents UInt16 value.
Public property UInt8 Property that represents UInt8 value.
Top
Methods
  Name Description
Top
See Also

©  Bricsys NV. All rights reserved.