DictionaryAtPut(String, RXObject,
RXObject) Method
|
Adds to the dictionary a value with given
id.
Namespace: Teigha.Runtime
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
25.3.0.0
Syntax
public virtual void AtPut(
string key,
RXObject value,
out RXObject oldValue
)
Public Overridable Sub AtPut (
key As String,
value As RXObject,
<OutAttribute> ByRef oldValue As RXObject
)
public:
virtual void AtPut(
String^ key,
RXObject^ value,
[OutAttribute] RXObject^% oldValue
)
abstract AtPut :
key : string *
value : RXObject *
oldValue : RXObject byref -> unit
override AtPut :
key : string *
value : RXObject *
oldValue : RXObject byref -> unit
Parameters
- key String
-
- value RXObject
-
- oldValue RXObject
- [out] Old item value at a given key or null if the dictionary
was set up to delete its entries. Caller of the function must take
care of disposing the oldValue at the right time.
See Also