Dictionary Class

Inheritance Hierarchy
SystemObject
  SystemMarshalByRefObject
    Teigha.RuntimeDisposableWrapper
      Teigha.RuntimeRXObject
        Teigha.RuntimeDictionary

Namespace: Teigha.Runtime
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 25.3.0.0
Syntax
public class Dictionary : RXObject, IDictionary

The Dictionary type exposes the following members.

Constructors
  Name Description
Protected method Dictionary Initializes a new instance of the Dictionary class
Top
Properties
  Name Description
Public property Count Property that represents the number of items in the dictionary object.
Public property DeletesObjects  
Protected property IDictionary_Item  
Public property IsCaseSensitive Property that indicates whether the keywords of the dictionary object are case-sensitive.
Protected property IsFixedSize  
Protected property IsReadOnly  
Public property IsSorted Property that indicates whether the dictionary is sorted.
Protected property IsSynchronized  
Public property Item Property that represents an entry in the dictionary according to the keyword.
Protected property Keys  
Protected property SyncRoot  
Protected property Values  
Top
Methods
  Name Description
Public method At(Int32) Returns value from the dictionary at the given id.
Public method At(String) Returns value from the dictionary at the given key.
Public method AtKeyAndIdPut Adds to the dictionary a value with given id, then resets the key for this id to the given value.
Public method AtPut(Int32, RXObject) Adds to the dictionary a value with given id.
Public method AtPut(String, RXObject) Adds to the dictionary a value with given key.
Public method AtPut(Int32, RXObject, RXObject) Adds to the dictionary a value with given id.
Public method AtPut(String, RXObject, Int32) Adds to the dictionary a value with given key. In retId returns id assigned to this value.
Public method AtPut(String, RXObject, RXObject) Adds to the dictionary a value with given id.
Public method AtPut(String, RXObject, Int32, RXObject) Adds to the dictionary a value with given key. In retId returns id assigned to this value.
Public method Contains(Int32) Checks whether the dictionary contains an item for the specified id.
Public method Contains(String) Checks whether the dictionary contains an item for the specified key.
Public method CopyTo Copies entries from this dictionary to the specified array.
Public method GetEnumerator Returns an enumerator object for the collection.
Protected method ICollection_CopyTo  
Public method IdAt Returns the ID of the item specified by the keyword in the dictionary object.
Protected method IDictionary_Add  
Protected method IDictionary_Clear  
Protected method IDictionary_Contains  
Protected method IDictionary_Remove  
Protected method IEnumerable_GetEnumerator  
Public method KeyAt Returns the keyword of the item specified by the ID in the dictionary object.
Public method Remove(Int32) Removes the item specified by keyword or ID from the dictionary object.
Public method Remove(String) Removes the item specified by keyword from the dictionary object.
Public method ResetKey(Int32, String) Sets the keyword for the item specified by ID for the dictionary object.
Public method ResetKey(String, String) Sets the new keyword for the item specified by an old keyword for the dictionary object.
Top
See Also

©  Bricsys NV. All rights reserved.