IMenuItem Interface

This is an interface for working with menu items.

Namespace: Teigha.Runtime
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 25.3.0.0
Syntax
public interface IMenuItem

The IMenuItem type exposes the following members.

Properties
  Name Description
Public property Checked Property that indicates whether the menu item is checked.
Public property Enabled Property that indicates whether the menu item is enabled.
Public property Icon Property that represents the icon of a menu item.
Public property Items Property that represents the collection of sub-items of a menu item.
Public property Text Property that represents the text string of a menu item.
Public property Visible Property that indicates whether the menu item is visible.
Top
Methods
  Name Description
Public method OnClicked Invokes the Click event.
Top
Events
  Name Description
Public event Click Event handler for click events.
Top
See Also

©  Bricsys NV. All rights reserved.