Export
|
The ExportContext type exposes the following members.
Name | Description | |
---|---|---|
![]() |
AutoDelete | (Inherited from DisposableWrapper) |
![]() |
IsDisposed | (Inherited from DisposableWrapper) |
![]() |
UnmanagedObject | (Inherited from DisposableWrapper) |
Name | Description | |
---|---|---|
![]() |
CreateObjRef | Creates an object that contains all the relevant information
required to generate a proxy used to communicate with a remote
object. (Inherited from MarshalByRefObject) |
![]() |
DeleteUnmanagedObject | (Overrides DisposableWrapperDeleteUnmanagedObject) |
![]() |
Dispose | (Inherited from DisposableWrapper) |
![]() |
Dispose(Boolean) | (Inherited from DisposableWrapper) |
![]() |
Equals | (Inherited from DisposableWrapper) |
![]() |
Finalize | (Inherited from DisposableWrapper) |
![]() |
GetAxis2Placement2D | |
![]() |
GetAxis2Placement3D | |
![]() |
GetCartesianPoint2D | |
![]() |
GetCartesianPoint3D | |
![]() |
GetDatabase | |
![]() |
GetDirection2D | |
![]() |
GetDirection3D | |
![]() |
GetHashCode | (Inherited from DisposableWrapper) |
![]() |
GetIfcModel | |
![]() |
GetLifetimeService | Retrieves the current lifetime service object that controls the
lifetime policy for this instance. (Inherited from MarshalByRefObject) |
![]() |
GetProduct(FullSubentityPath) | |
![]() |
GetProduct(ObjectId) | |
![]() |
GetType | Gets the Type of the current
instance. (Inherited from Object) |
![]() |
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime
policy for this instance. (Inherited from MarshalByRefObject) |
![]() |
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object) |
![]() |
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject) |
![]() |
SetIfcRootData | |
![]() |
SetLocationRelToAssignedSpatialLocation | |
![]() |
SetLocationRelToBuilding | |
![]() |
SetLocationRelToStory | |
![]() |
SetLocationRelToWCS | |
![]() |
SetMaterialToAssignedComposition | |
![]() |
SetMaterialToComposition | |
![]() |
SetRepresentationAsBrep | |
![]() |
SetRepresentationAsClippedExtrudedAreaSolid | |
![]() |
SetRepresentationAsExtrudedAreaSolid | |
![]() |
ToString | Returns a string that represents the current object. (Inherited from Object) |
© Bricsys NV. All rights reserved. |