DictionaryAtPut(Int32, RXObject,
RXObject) Method
|
Adds to the dictionary a value with given
id.
Namespace: Teigha.Runtime
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
25.3.0.0
Syntax
public virtual void AtPut(
int id,
RXObject value,
out RXObject oldValue
)
Public Overridable Sub AtPut (
id As Integer,
value As RXObject,
<OutAttribute> ByRef oldValue As RXObject
)
public:
virtual void AtPut(
int id,
RXObject^ value,
[OutAttribute] RXObject^% oldValue
)
abstract AtPut :
id : int *
value : RXObject *
oldValue : RXObject byref -> unit
override AtPut :
id : int *
value : RXObject *
oldValue : RXObject byref -> unit
Parameters
- id Int32
- [in] Item id as an integer value; must be positive and
unique.
- value RXObject
-
- oldValue RXObject
- [out] Old item value at a given id. Null if the dictionary was
set up to delete its entries. Caller of the function must take care
of disposing the oldValue at the right time.
See Also