PointOnSurfaceGetInverseTangentVector(Vector3d,
Surface, Point2d) Method
|
Projects the specified vector onto the tangent
plane of the provided surface at the specified parameter point (u,
v) and returns the 2D parameter space vector that maps to the
projected vector. Currently not implemented.
Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
25.3.0.0
Syntax
public static Vector2d GetInverseTangentVector(
Vector3d vector,
Surface surf,
Point2d point
)
Public Shared Function GetInverseTangentVector (
vector As Vector3d,
surf As Surface,
point As Point2d
) As Vector2d
public:
static Vector2d GetInverseTangentVector(
Vector3d vector,
Surface^ surf,
Point2d point
)
static member GetInverseTangentVector :
vector : Vector3d *
surf : Surface *
point : Point2d -> Vector2d
Parameters
- vector Vector3d
- [in] 3D vector to project.
- surf Surface
- [in] 3D surface.
- point Point2d
- [in] 2D point on the surface.
Return Value
Vector2d
See Also