PointOnSurfaceGetInverseTangentVector(Vector3d, Point2d) Method

Projects the specified vector onto the tangent plane at the specified point and returns the 2D parameter space vector that maps to this projected vector.

Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 25.3.0.0
Syntax
public Vector2d GetInverseTangentVector(
        Vector3d vector,
        Point2d point
)

Parameters

vector  Vector3d
[in] 3D vector.
point  Point2d
[in] 2D parameter point for this surface.

Return Value

Vector2d
See Also

©  Bricsys NV. All rights reserved.