DatabaseSaveAs(StreamBuf,
SaveType, DwgVersion, Boolean, Int32)
Method
|
Saves content of the currently active database
according to the passed arguments.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
25.3.0.0
Syntax
public void SaveAs(
StreamBuf fileBuf,
SaveType st,
DwgVersion version,
bool saveThumbnailImage,
int dxfPrecision
)
Public Sub SaveAs (
fileBuf As StreamBuf,
st As SaveType,
version As DwgVersion,
saveThumbnailImage As Boolean,
dxfPrecision As Integer
)
public:
void SaveAs(
StreamBuf^ fileBuf,
SaveType st,
DwgVersion version,
bool saveThumbnailImage,
int dxfPrecision
)
member SaveAs :
fileBuf : StreamBuf *
st : SaveType *
version : DwgVersion *
saveThumbnailImage : bool *
dxfPrecision : int -> unit
Parameters
- fileBuf StreamBuf
- [in] Stream buffer to which to write the database.
- st SaveType
- [in] Save type represented by the SaveType enumeration.
- version DwgVersion
- [in] A file version to which to save the file.
- saveThumbnailImage Boolean
- [in] Flag that indicates whether to save a thumbnail
image.
- dxfPrecision Int32
- [in] .dxf file decimal digits precision. Currently ignored; a
value of 16 is used.
See Also