StreamBuf Class

This class provides platform-dependent I/O for the ODA Platform.
Inheritance Hierarchy
SystemObject
  SystemMarshalByRefObject
    Teigha.RuntimeDisposableWrapper
      Teigha.RuntimeRXObject
        Teigha.RuntimeStreamBuf
          Teigha.RuntimeFileStreamBuf
          Teigha.RuntimeMemoryStreamBuf

Namespace: Teigha.Runtime
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 25.3.0.0
Syntax
public abstract class StreamBuf : RXObject

The StreamBuf type exposes the following members.

Constructors
  Name Description
Public method StreamBuf Default constructor for the StreamBuf class.
Top
Properties
  Name Description
Public property FileName This property represents name of the file associated with this StreamBuf object.
Public property IsEof This property indicates whether current position of the file pointer for this StreamBuf object is at the end of file.
Public property Length This property represents the length in bytes of the file associated with this StreamBuf object.
Public property ShareMode This property represents the share mode for this StreamBuf object. It can be: ValueDescription0x10 deny read/write mode 0x20 deny write mode 0x30 deny read mode 0x40 deny none mode
Public property Tell This property represents the current position of the file pointer for this StreamBuf object.
Top
Methods
  Name Description
Public method CopyTo(StreamBuf) Copies bytes from this StreamBuf object to the specified StreamBuf object.
Public method CopyTo(StreamBuf, UInt64) Copies bytes from this StreamBuf object to the specified StreamBuf object.
Public method CopyTo(StreamBuf, UInt64, UInt64) Copies bytes from this StreamBuf object to the specified StreamBuf object.
Public method Read Reads a byte at current position of a file pointer.
Public method Read(UInt32) Reads the specified number of bytes at current position of a file pointer.
Public method Rewind Sets the current position of the file pointer for this StreamBuf object to zero.
Public method Seek Moves the current position of the file pointer for this StreamBuf object to the specified location.
Public method Truncate Sets the length of the file associated with this StreamBuf object to zero.
Public method Write(Byte) Writes the byte to the current position of the file pointer for this StreamBuf object, and increments the pointer.
Public method Write(Byte, UInt32) Writes the specified amount of bytes to the current position of the file pointer for this StreamBuf object, and increments the pointer by the specified amount.
Top
See Also

©  Bricsys NV. All rights reserved.