PolylineCurve2d(KnotCollection,
Point2dCollection) Constructor
|
Constructor for the PolylineCurve2d class.
Creates a polyline with the specified knots and point values.
Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
25.3.0.0
Syntax
public PolylineCurve2d(
KnotCollection knots,
Point2dCollection controlPoints
)
Public Sub New (
knots As KnotCollection,
controlPoints As Point2dCollection
)
public:
PolylineCurve2d(
KnotCollection^ knots,
Point2dCollection^ controlPoints
)
new :
knots : KnotCollection *
controlPoints : Point2dCollection -> PolylineCurve2d
Parameters
- knots KnotCollection
- [in] Knot vector.
- controlPoints Point2dCollection
- [in] Array of 2D points with which a polyline is
constructed.
See Also