DictionaryAtPut(String, RXObject,
Int32, RXObject) Method
|
Adds to the dictionary a value with given key.
In retId returns id assigned to this value.
Namespace: Teigha.Runtime
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
25.3.0.0
Syntax
public virtual void AtPut(
string key,
RXObject value,
out int retId,
out RXObject oldValue
)
Public Overridable Sub AtPut (
key As String,
value As RXObject,
<OutAttribute> ByRef retId As Integer,
<OutAttribute> ByRef oldValue As RXObject
)
public:
virtual void AtPut(
String^ key,
RXObject^ value,
[OutAttribute] int% retId,
[OutAttribute] RXObject^% oldValue
)
abstract AtPut :
key : string *
value : RXObject *
retId : int byref *
oldValue : RXObject byref -> unit
override AtPut :
key : string *
value : RXObject *
retId : int byref *
oldValue : RXObject byref -> unit
Parameters
- key String
- [in] Item key as a string value.
- value RXObject
- [in] Item which is being added to the dictionary.
- retId Int32
- [out] Id which is being assigned to this entry.
- oldValue RXObject
- [out] Old item value at a given key or null if the dictionary
was set up to delete its entries or there was nothing at this key.
Caller of the function must take care of disposing the oldValue at
the right time.
See Also