remove

Parent Previous Next

remove


(remove  item  list)

returns the input list, with item removed from the list

Arguments

'item' any valid Lisp value to be removed from the list
'list' any valid Lisp list

Return

the input list with all occurrences of 'item' removed from the list

Example

(remove 1 '( 0 1 1 2 3)) => (0 2 3)

Alias


Remarks

all occurrences of 'item' are removed from the list;
this function is deprecated; please use (vl-remove) or (vle-remove-all)




©  Menhirs NV. All rights reserved.