Class AcadApplication
Member of BricscadApp
The Application object represents an instance of the BricsCAD application.
The properties associated with the Application object reflect the properties of the main application window. The methods control the loading or listing of the currently loaded external applications and interface objects. The active document (BricsCAD drawing) can be accessed using the ActiveDocument property.
Use the Quit method to end the BricsCAD session.
Methods | Properties | Events |
---|---|---|
DefineFunction | ActiveDocument | AppActivate |
GetAcadState | Application | AppDeactivate |
GetInterfaceobject | Caption | ARXLoaded |
ListArx | Documents | ARXUnloaded |
LoadArx | FullName | BeginCommand |
LoadDVB | Height | BeginFileDrop |
Quit | HWND | BeginLisp |
RunCommand | LocaleID | BeginModal |
RunMacro | MenuBar | BeginOpen |
RunScript | MenuGroups | BeginPlot |
UndefineFunction | Name | BeginQuit |
UnloadArx | Path | BeginSave |
UnloadDVB | Preferences | EndCommand |
Update | StatusId * | EndLisp |
ZoomAll | VBE * | EndModal |
ZoomCenter | Version | EndOpen |
ZoomExtents | Visible | EndPlot |
ZoomPickWindow | Width | EndSave |
ZoomPrevious | LispCancelled | |
ZoomScaled | NewDrawing | |
ZoomWindow | WindowTop | SysVarChanged |
WindowChanged | ||
WindowMovedOrResized | ||
© Bricsys NV. All rights reserved. |