bim:get-roomassignedbuilding


(bim:get-roomassignedbuilding  roomEntity)

Returns the name of the building where the BIM room specified by roomEntity is assigned to.

Arguments

roomEntity  room entity of an existing room (ename), as returned by (bim::create-room) and (bim::create-associativeroom), or other room functions

Return

the name of the building (string) where "roomEntity" is assigned to, or NIL if no building is assigned or the specified "roomEntity" is not a valid room

Example

(bim:get-roomassignedbuilding roomEnt1)  "Tower"
(bim:get-roomassignedbuilding roomEnt2x)  NIL

Remarks

since V21 : this function also works with the new "Spaces" objects;
see (bim::create-room), (bim::create-associativeroom), (bim:get-room) or (bim:get-allrooms)



©  Bricsys NV. All rights reserved.