bim:get-roomassignedstory


(bim:get-roomassignedstory  roomEntity)

Returns the name of the story where the BIM room specified by roomEntity is assigned to.

Arguments

roomEntity  room entity of an existing room (ename), as returned by (bim::create-room) and (bim::create-associativeroom), or other room functions

Return

the name of the story (string) where "roomEntity" is assigned to, or NIL if no story is assigned or the specified "roomEntity" is not a valid room

Example

(bim:get-roomassignedstory roomEnt1)  "Floor-1"
(bim:get-roomassignedstory roomEnt2x)  NIL

Remarks

since V21 : this function also works with the new "Spaces" objects;
see (bim::create-room), (bim::create-associativeroom), (bim:get-room) or (bim:get-allrooms)



©  Bricsys NV. All rights reserved.