bim:pset-get-property


(bim:pset-get-property  ename  propertyset  name)

Returns the value of the specified property name in PropertySet propertyset, for the specified entity ename.

Arguments

ename  (ename) the entity to retrieve the property value from

propertyset  (string) the PropertySet name (as Name or Label, case-insensitive)

name  (string) the name of the Property (as Name or Label, case-insensitive) to be retrieved the value for

Return

the value of the property, or NIL (if the PropertySet or the Property does not exist)

Example

(bim:pset-get-property ent "MyPropertySet" "MyTag-A")  "floor"

Remarks

the Property name is case-insensitive;
the PropertySet name/label is case-insensitive;
all PropertyNameSpaces are automatically used to find the specified PropertySet



©  Bricsys NV. All rights reserved.