bim:pset-has-property


(bim:pset-has-property  ename  propertyset  name)

Returns whether the specified entity ename has a property name of PropertySet propertyset.

Arguments

ename  (ename) the entity to be verified

propertyset  (string) the PropertySet name (as Name or Label, case-insensitive)

name  (string) the name of the Property to be verified

Return

T or NIL (if the PropertySet or the Property does not exist)

Example

(bim:pset-has-property ent "MyPropertySet" "MouTag")  NIL
(bim:pset-set-property ent "MyPropertySet" "MouTag" "abc")  T
(bim:pset-has-property ent "MyPropertySet" "MouTag")  T
(bim:pset-get-property ent "MyPropertySet" "MouTag")  "abc"

Remarks

the Property name is case-insensitive;
the PropertySet name/label is case-insensitive;
all PropertyNameSpaces are automatically used to find the specified PropertySet



©  Bricsys NV. All rights reserved.