bim:pset-list-properties


(bim:pset-list-properties  propertyset)

Returns a list of all defined properties for the specified PropertySet propertyset.

Arguments

propertyset  (string) the name of the PropertySet (as Name or Label, case-insensitive) to retrieve

Return

list of property definition entries, or NIL (if the ProeprtySet does not exist, or does not contain any Property);
each property definition entry is defined as :
(name  description  type)  name, description and type are all strings

the "type" string is one of the following (always lowercase) :



"integer"

specifies a Lisp INT fixed number


"double"

specifies a Lisp REAL floating point number


"string"

specifies a Lisp STR string


"point2d"

specifies a Lisp 2d point (x y)


"point3d"

specifies a Lisp 3d point (x y z)


"objectid"

specifies a Lisp ENAME

Example

(bim:pset-list-properties "Pset_ConcreteElementQuantityGeneral")
(("TotalConcreteQuantity" "The total bulk quantity of concrete used for the precast concrete element expressed as the volume of concrete in cubic meter (m3)." "double"))

Remarks

the PropertySet name/label is case-insensitive;
all PropertyNameSpaces are automatically used to find the specified PropertySet



©  Bricsys NV. All rights reserved.